What do I need to use EM-COP?

You will need a computer or tablet device with a web browser and internet access.  The supported browsers are:

  • Google Chrome version 52
  • Firefox 47.0
  • Apple Safari 9.1
  • Internet Explorer 11 

or later versions of any of the above listed browsers.

NOTE:  EM-COP will detect your browser and if you are using an old or unsupported browser you will see a screen message letting you know you need to update your browser.  You can continue to sign in to EM-COP but you may experience issues with some functions.

Have more questions? Submit a request

0 Comments

Article is closed for comments.